redis requires Ruby version >= 2.2.2问题

摘要: redis requires Ruby version >= 2.2.2问题

最近在研究redis的集群,redis官方提供了redis-trib.rb工具,但是在使用之前 需要安装ruby,以及redis和ruby连接:

1
2
# yum -y install ruby ruby-devel rubygems rpm-build
# gem install redis

其中 gem install redis命令执行时出现了:

redis requires Ruby version >= 2.2.2的报错,查了资料发现是Centos默认支持ruby到2.0.0,可gem 安装redis需要最低是2.2.2

解决办法是 先安装rvm,再把ruby版本提升至2.3.3

  • 安装curl
1
# sudo yum install curl
  • 安装RVM
1
# curl -L get.rvm.io | bash -s stable
  • 编译RVM
1
# source /usr/local/rvm/scripts/rvm
  • 查看rvm库中已知的ruby版本
1
# rvm list known
  • 安装一个ruby版本
1
# rvm install 2.3.3
  • 使用一个ruby版本
1
# rvm use 2.3.3
  • 设置默认版本
1
# rvm remove 2.0.0
  • 卸载一个已知版本
1
# ruby --version
  • 再安装redis就可以了
1
# gem install redis

参考博客:

http://blog.csdn.net/lixwjava/article/details/50408070

http://blog.csdn.net/fengye_yulu/article/details/77628094
原文地址:
https://www.cnblogs.com/carryping/p/7447823.html

评论